BMW R1200R Forum banner
1 - 20 of 50 Posts

· Premium Member
2017 R1200R
Joined
·
54 Posts
Discussion Starter · #1 ·
The nav v1 on my 2017 R1200R has developed a fault. When you turn off engine I used to be able to select a softky to turn off navigator immediately. The button turns blue but nothing happens. When riding the screen flicks around sometimes aligning west then east etc. Another problem is the screen flicks left and right as if it is losing GPS then suddenly finds it again.

Any suggestions, please? If it does need to be repaired I presume the only choice is a return to BMW. Are there any independent repair shops in US, please?

Thanks
 

· Registered
Joined
·
1,009 Posts
I presume you mean the Navigator VI (6)?

I’m on my 4th unit (3 replacements).

Garmin buggered the QC/QA on this model and had been hustling to address all the unhappy owners. If the unit is prompting you to turn off or remain on, try opting to remain on. As you may know, the unit does this twice (annoying as f***). Once when you turn bike off. Again when the CANbus cuts all power to the cradle. See if it does this in both prompts.

Next, can you access the GPS via computer and Garmin cable? If so, Garmin will want you to try and troubleshoot the issue before sending you a new unit. If not, they likely will just arrange a replacement unit.


If not already done, you need to sign up and register your unit. I can’t say I’ve had your precise issue, but I’ve had my unit act like it was possessed (older replacement) and my last swap was when the comm port stopped working...so I couldn’t get it to interface with my PC.

If you send it back, remember to remove your memory card if one‘s inserted, and if you can interface with Garmin Express, use the application to back up your GPS…it will make it much easier to reconfigure your replacement unit over doing it manually. ALSO, if you have music/podcasts and playlists on the unit, copy them to your PC before shipping. The VI is a POS when it comes to creating and organizing music to a playlist. I spent hours reprogramming mine because I didn’t back up the playlist files from the old unit.
 
  • Like
Reactions: dbyker

· Mark – Moderator 2015 R1200R-LC Exclusive
2015 R1200R Exclusive
Joined
·
7,951 Posts
You might find this thread relevant
 
  • Like
Reactions: dbyker

· Premium Member
2017 R1200R
Joined
·
54 Posts
Discussion Starter · #5 ·
I presume you mean the Navigator VI (6)?

I’m on my 4th unit (3 replacements).

Garmin buggered the QC/QA on this model and had been hustling to address all the unhappy owners. If the unit is prompting you to turn off or remain on, try opting to remain on. As you may know, the unit does this twice (annoying as f***). Once when you turn bike off. Again when the CANbus cuts all power to the cradle. See if it does this in both prompts.

Next, can you access the GPS via computer and Garmin cable? If so, Garmin will want you to try and troubleshoot the issue before sending you a new unit. If not, they likely will just arrange a replacement unit.


If not already done, you need to sign up and register your unit. I can’t say I’ve had your precise issue, but I’ve had my unit act like it was possessed (older replacement) and my last swap was when the comm port stopped working...so I couldn’t get it to interface with my PC.

If you send it back, remember to remove your memory card if one‘s inserted, and if you can interface with Garmin Express, use the application to back up your GPS…it will make it much easier to reconfigure your replacement unit over doing it manually. ALSO, if you have music/podcasts and playlists on the unit, copy them to your PC before shipping. The VI is a POS when it comes to creating and organizing music to a playlist. I spent hours reprogramming mine because I didn’t back up the playlist files from the old unit.
What a forum. Thank you for your detailed response. I'm pretty sure there is no fix I can do so back to garmin. Do I need to go through bmw or straight to garmin? Any advice on how to position problem with garmin. Unit is 4 years old. I've dealt with garmin before with marine electronics problem...just like their manuals...bloody nightmare. Any advice on handling them appreciated!
 

· Registered
Joined
·
1,009 Posts
You should go through BMW as it's their product.
No. For the USA at least, unless you just got it from a BMW shop, they will refer you to Garmin. It’s Garmin’s product made for BMW. Again, follow the link I gave, sign up and register your product. Then contact support. If the unit works enough to try diagnostic tests, they will ask you to try it before authorizing a replacement, but they’ve been good (so far) at no hassle replacement once they determine it can’t be fixed on your end.

If it works with your PC (be sure to NOT use a USB 3.0 port as sometimes that causes communication issues), if you get it recognized by Garmin Express, back up your unit to make formatting a replacement easier and back up playlist data and files as well.
 

· Mark – Moderator 2015 R1200R-LC Exclusive
2015 R1200R Exclusive
Joined
·
7,951 Posts
Thanks @zer0netgain. In Oz, BMW handle it because it is a BMW badged product and they market them exclusively. The dealer will simply send it back to the BMW Motorrad for replacement. When I took my faulty unit in, the service manager had a stack of replacement claims on his desk, and no questions were asked.

Good advice on the USB3 too - I was once stymied for hours by that one.
 

· Premium Member
2017 R1200R
Joined
·
54 Posts
Discussion Starter · #8 ·
Thanks all. Spoke to Garmin and they are replacing at no cost. The unit I had on my 2017 was according to garmin a 2020 unit so must have been replaced before. The warranty in their mind runs for 5 years from that date which is a bit of a win! Unit on its way to me. All hassle free.
 

· Registered
Joined
·
14 Posts
What a forum. Thank you for your detailed response. I'm pretty sure there is no fix I can do so back to garmin. Do I need to go through bmw or straight to garmin? Any advice on how to position problem with garmin. Unit is 4 years old. I've dealt with garmin before with marine electronics problem...just like their manuals...bloody nightmare. Any advice on handling them appreciated!
Go to Garmin's website (Garmin International | Home), call support and let them know your touch screen is malfunctioning. They will send a label and shipping instructions. When they receive your old unit they will send out a new one. Tech told me today that they have resolved the problem with the new units. I just sent in my second Navigator VI and hope to receive the third soon.
 

· Registered
Beatrix - 2020 BMW R1250R Exclusive in Pollux Metallic Matte
Joined
·
534 Posts
My Nav6 experienced the infamous screen ghosting problem, where the touch screen was registering fantom touches. Oddly enough, it happens only when temperatures dropped below 45`F (~7'C). A quick search online confirmed that it was a known issue, and Garmin replaced affected units without much hesitation. A quick call to Garmin: they provided a pre-paid return shipping label, and said they would replace the unit, once received. The whole process should take a couple of weeks.

Interesting fact: if I were to need a navigator before I send the defective one back, Garmin would place a credit hold of $340 or so until they receive the old unit back. The total price of $999 US for a new in a box from BMW seems a "bit" inflated, right :)

Here is a photo of my old unit hardware info that developed the screen ghosting problem, in case if it helps anyone. Bike and navigator used for about 6,000 miles.

I'll post an update when a replacement unit arrives and I had a chance to test it.

Font Gadget Electronic device Rectangle Wood
 

· Mark – Moderator 2015 R1200R-LC Exclusive
2015 R1200R Exclusive
Joined
·
7,951 Posts
While working on the clutch switch last night mine displayed similar symptoms, which surprised me as it is already a replacement unit. A quick wipe of the screen sorted it.

Interestingly though it was autonomously flicking to the BMW dealer locations list - perhaps trying to tell me to just go and buy a new switch. 😄
 

· Registered
Beatrix - 2020 BMW R1250R Exclusive in Pollux Metallic Matte
Joined
·
534 Posts
Garmin shipped a replacement Nav6, should be here this weekend. Will report if the issue is fixed.
 
  • Like
Reactions: Panzermann

· Retired In Beautiful Tennessee
Joined
·
1,781 Posts
Note: Merged & renamed a couple previous Nav VI threads to hopefully improve future searchability.

Started having issues with my four year old Nav VI - screen ghosting, not turning on/off with bike, and short battery life. Contacted Garmin at their US support link below (scroll down to call, chat or email).

BMW Motorrad Navigator VI | Garmin Support

After a short chat they agreed to replace it with a refurb unit free under warranty. Shipped the old unit to them with their address label, and they sent the new refurb unit back ten days later. Works perfectly so far, very satisfied.

Cheers, Dave
 
  • Like
Reactions: Panzermann

· Registered
Joined
·
211 Posts
I also just returned my NAV VI to Garmin for replacement after only 6K due to the ghosting problem.
The inputs on the home screen also quit.
BTW, it was a pretty cold day and apparently that is a contributing factor for malfunctions.
42F
I made a YouTube video for the dealer at the end of my ride in case they needed proof, but after some forum research, I realized it was the "ghosting" problem and called Garmin.

 

· Registered
Beatrix - 2020 BMW R1250R Exclusive in Pollux Metallic Matte
Joined
·
534 Posts
Had a chance to test the replacement unit on a few rides, one of them at 36`F, and afterwards where bike was parked all day outside in below 40`F and substantial windchill (Nav6 was in the docking cradle). Touch screen works just fine for now. Before, in temperatures below 50`F, screen would register ghost touches, and image would jump around.

I've also added a 32 GB micro-SD card, even though I don't know yet what I will use it for :)

Hardware version appears to be the same, so not sure what exactly changed from previous unit to this unit. The only notable differences in the NavVI "About" submenue:
  • BMW Mottorrad: is now version 16.00 vs. old unit having 13.00
  • Mount Version: 3.00 - this is new, as it has not been there before.
As with the previous unit, I've added a SpeedAngels screen protector to the NavVI

Font Display device Electronic device Multimedia Projector accessory
 

· Registered
Beatrix - 2020 BMW R1250R Exclusive in Pollux Metallic Matte
Joined
·
534 Posts
I was throwing away the packaging from my replacement BMW Garmin Nav VI unit; and noticed that is says "GARMIN RECERTIFIED". I guess, I was sent a refurbished unit, with a new('er) battery, which was made in 6/2021.
 

· Registered
Beatrix - 2020 BMW R1250R Exclusive in Pollux Metallic Matte
Joined
·
534 Posts
My replacement Garmin Navigator VI experienced a ghosting problem, yet again. Only a handful of rides, most of which were arguably on cold days. Thankfully, issue presented itself on a short ride, 42`F outside, and I didn't really need to rely on navigation to get me to my destination. BMW and Garmin really dropped the ball on this $1,000 accessory. This time Garmin representative assured me that they are sending a brand new replacement unit, rather than a refurbished. He said the issue should have been fixed, but I honestly don't know...
Will report in a couple of weeks...

:cautious::cautious::cautious::cautious::cautious:
 
  • Like
Reactions: dbyker

· Mark – Moderator 2015 R1200R-LC Exclusive
2015 R1200R Exclusive
Joined
·
7,951 Posts
I got a brand new replacement a long while back and it’s been completely reliable.
 

· Retired In Beautiful Tennessee
Joined
·
1,781 Posts
The replacement they sent me a month ago is a refurb with a new battery. Need to do some cold weather rides to really test it out. Kept a copy of all the paperwork just in case.

They screwed the pooch on the Nav VI but are standing behind it so far, rare these days.

Cheers! Dave
 

· Registered
Beatrix - 2020 BMW R1250R Exclusive in Pollux Metallic Matte
Joined
·
534 Posts
I got a brand new replacement a long while back and it’s been completely reliable.
Do you use a screen protector? Could the ghosting problem somehow be caused by it? I had a Spedo Angels screen protector on my original Nav VI (4,500 miles with screen protector), and it only started acting up in the cold…
 
1 - 20 of 50 Posts
Top